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ADOBE PREMIERE PRO FOR COMPLETE BEGINNERS 
by Navin Kulshreshtha, Lead Instructor at LearnPremiere.com 

 
WEEK 1 SUMMARY 

 
Download Media 

• Welcome to the course! Be sure to download the course media from the 
course page, which is contained in a ZIP file. You can access the course page 
by going to LearnPremiere.com and clicking on My Account.  

• Then unzip the file and place the contents in an easy-to-find location on your 
computer such as your Desktop.  

 
STEP 1: Get Organized!  

• Create a project folder and give it a descriptive name such as Zoo-Video or 
similar. In the example below the folder is called Skateboarding-Video.  

• Inside the project folder, create several subfolders to keep the project 
organized. Here is an example:  
 

 
 

• Place all your media inside the 01-Media folder.  
• Start Premiere Pro and create a new project file by choosing File > New > 

Project from the top menu.  
• Click on the Browse button and navigate to the 02-Project-Files folder. 
• Give the file name a descriptive name such as Zoo-Video-Edit or similar.  
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STEP 2: Import Media 
• Choose File > Import > Media and browse to the 01-Media folder.  
• Select all of the media files and import. 
• To select a range of files, click on the first file then Shift-click on the last 

one.   
• Each of the little windows inside Premiere Pro is called a Panel. And the 

arrangement of panels on the screen is called a Workspace.  
• Change to the Editing workspace by choosing Window > Workspaces > 

Editing from the top menu.  
• If necessary you can reset the workspace by choosing Window > 

Workspaces > Reset to Saved Layout. 
 
STEP 3: Browse Media 

• Your media will appear in  the Project Panel. 

• Move your mouse over the Project Panel and use the Accent/Tilde  key  
to maximize the panel. This key is below the Esc key on many computers: 
 

 
 

• Use the buttons at the bottom of the panel to switch between List View and 
Icon View.  

• Drag the Zoom Slider to change the size of the icons.  
• Use the Sort Icons button to change the sort order (only works in Icon view) 

and then choose Name to sort alphabetically by clip name. 
 



© Copyright Navin Kulshreshtha. All rights reserved.  3 

 
 

• Move your mouse (without clicking) from left to right over top of a clip to 
preview it. This is called Hover Scrub. 

• Single-click a clip to select it. Hover Scrub will not work, but you can drag the 
rectangular playhead to preview it.  

•  Double-click a clip to open it in the Source Monitor.  
 
STEP 4: Select Media 
 

 
 

• Use the Up arrow key   on your keyboard to go to the beginning of the clip. 
The Home button will also work, if your keyboard has it. 

• Use the Spacebar on your keyboard to play and stop the video. You can also 
use the Play/Stop button in the Source Monitor. 

• Use the keyboard shortcut I or the Mark In button or to mark the beginning 
of your selection. 
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• Use keyboard shortcut O or the Mark Out button to mark the end of your 
selection. 

• The times are in format hours:minutes:seconds:frames so 00:00:15:00 would 
be 15 seconds.  

 
STEP 5: Timeline 

• Add a clip to the Timeline by dragging and dropping it. 
• Increase the track height by double-clicking the empty space in the track 

header. See screenshot below:  
 

 
 

• The scroll bar at the bottom allows you to move and zoom in the Timeline.  
 

 
 
 
STEP 6: Refine the Edit 
 
Trimming Clips:  

• Be sure to have the Selection tool active in the Tools panel.  
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• Trim a clip in the Timeline by dragging the edges of it. Look for the red arrow 
when trimming.  

• Remove a gap by right-clicking it and choosing Ripple Delete. If you don't 
have a right-click, Ctrl-click often works.  

• To extend a clip you may have to move a neighboring clip out of the way by 
dragging it. Select multiple clips by selecting them with your mouse and then 
dragging them.  

 
Using Razor Blade Tool to Trim 

• Select the Razor tool from the Tools panel.  
• Click directly on a clip to split it into two pieces.  
• Select the Selection tool (black arrow) from the Tools panel.  
• Click on any extra clips in the Timeline and hit Delete on your keyboard to 

remove it.  
 
Moving Clips: 

• Be careful when dragging clips in the Timeline as you may overwrite or delete 
existing clips. 

• You can move clips by using Cut and Paste.  
• Cut a clip using Edit > Cut, or Cmd-X (Mac) or Ctrl-X (Windows). 
• Move through the Timeline one clip at a time by using the Up  and Down 

arrow keys on your keyboard.   
• Shift-drag the playhead to snap to an edit point, which is the exact point 

where two clips meet. 
• Paste the clip by using Edit > Paste Insert. Be sure you are at an edit point.  
• The fastest way to move a clip is to hold down Cmd on Mac or Ctrl on 

Windows (keep the button held down), then drag a clip to a new location, 
then release the Cmd or Ctrl button.  
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WEEK 2 SUMMARY 

 
List View 

• In the Project panel, click on the List View button.  
• Now you can see metadata for each clip including Frame Rate and the 

Video Info. 
• The Video Info column will show the frame size or resolution of the media.  

 
Common Video Resolutions 

• 3840 x 2160 - This is called UHD (ultra high definition) or 4K video.  
• 1920 x 1080 - This is called HD (high definition) video  
• 1280 x 720 
• 640 x 360 

 
Common Frame Rates 

• 30 fps 
• 29.97 fps 
• 25 fps 
• 24 fps 
• 23.976 fps 

 
Trimming with Selection Tool 

• With the Selection tool, move your mouse to the edge of the clip until your 
cursor becomes a red arrow.  

• Then click and drag to make the clip longer or shorter.  
 
Trimming with Razor Tool 

• Select the Razor tool from the Tools panel.  
• Click directly on a clip to split it into two pieces.  
• Select the Selection tool (black arrow) from the Tools panel.  
• Click on any extra clips in the Timeline and hit Delete on your keyboard to 

remove it. 
 
Deleting Gaps 

• Click on the gap and then hit Delete on your keyboard. 
• Or right-click the gap and choose Ripple Delete. 
• Or manually move clips in the Timeline to close the gap.  
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Adding an Interview 
• You would normally do this in the same manner as adding any other clip. 
• Usually you will mark In and Out points before adding to Timeline, but this is 

optional.  
 
B-Roll 

• This is additional or supplementary footage that is added to the Timeline.  
• Your main footage will be on Video Track 1, and the b-roll will be placed on 

Track 2 or higher.  
 
Unlinking Clips 

• By default, video and audio are linked together to form a clip. Where one 
goes, the other will follow.  

• To unlink the audio and video, right-click the clip in the Timeline and choose 
Unlink.  

• Now the audio and video will be separate, independent clips.  
• You can now delete any unnecessary audio or video.  

 
Still Images 

• You can add a still image to the Timeline like any other clip: Drag and drop.  
• By default a still image will be 5 seconds long, but you can adjust this in the 

Timeline.  
• Still images are often a different size than the video, either bigger or smaller, 

and can be resized to fit the video frame.  
 
Resizing an Image 

• Select the clip (image) in the Timeline.  
• From the top menu choose Window > Effect Controls. 
• In the Effect Controls panel, locate the Scale property. You may have to click 

on the triangle next to the word Motion to see it.  
• Increase or decrease the Scale value until you are happy with the size of the 

image.   
 
 

WEEK 3 SUMMARY 
 
Moving Clips by Dragging 

• You can drag clips around the Timeline. Just be careful because you will 
overwrite any clips in the way.  
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• So you may have to shuffle clips around to make space. This can be 
cumbersome in longer Timelines.  

  
Moving Clips with Cut and Paste 

• Cut a clip using Edit > Cut from the top menu, or shortcuts Cmd-X (Mac) or 
Ctrl-X (Windows). 

• Move to another point in the Timeline.  
• Paste the clip with Edit > Paste Insert from the top menu. Shortcuts are 

Cmd-Shift-V (Mac) or Ctrl-Shift-V (Windows).  
• When pasting, you will usually want to be at an edit point. An edit point 

(sometimes called an edit) is the exact point where two clips come together. 
• You can jump from edit to edit in Timeline by using the Up  and Down 

arrow keys on your keyboard.   
• You can also Shift-drag the playhead in the Timeline to snap to an edit 

point. 
 
Useful Preference Setting 

• From the top menu choose Premiere Pro > Preferences > Timeline (Mac) or 
Edit > Preferences > Timeline (Windows). 

• Enable this setting: 

 
• Now when you drag the Playhead in the Timeline it will automatically snap 

to edit points. No need to Shift-drag.  
 
Insert and Overwrite Buttons 

• These are located at the bottom of the Source Monitor, where you preview 
media.  
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Overwrite Edit 

• With this button, you will add the clip to the Timeline and overwrite any 
media in the Timeline. 

• You can also simply drag media into the Timeline to perform an overwrite 
edit.  

 
Insert Edit 

• With this button, you will insert the clip into the Timeline. Normally you will 
want to be at an edit point.  

 
Adding Music: 

• Double-click a music clip in the Project Panel to open it. Mark In and Mark 
Out if necessary.  

• Drag the music clip into the Timeline using the Drag Audio button. You can 
also drag directly from the Project Panel.  
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• Trim the music with the Razor tool if necessary. 
 
Mute and Lock 

• Mute a track by clicking the Mute button at the beginning of the track.  
• Lock a track by clicking the Lock button at the beginning of the track. This is 

especially useful when performing insert edits that may split the track 
accidentally.  
 

 
 
 
Resetting Workspace 

• If you accidentally close a panel or the workspace on your screen gets 
messed up, you can do the following: 

• From the top menu choose Window > Workspace > Editing, or the 
workspace of your choice.  

• Then choose Window > Workspaces > Reset to Saved Layout and the 
workspace should come back to normal.  

 
Patching Tracks 

• On occasion you may drag a clip into the Timeline, but it doesn't get added 
properly. Either the audio, video or both are missing!  

• If this happens make sure the correct tracks are patched. This is the first 
column of blue rectangles at the beginning of the Timeline: 



© Copyright Navin Kulshreshtha. All rights reserved.  11 

 
 

• In the example above V1 and A1 are patched (highlighted in blue) and 
everything should work normally.  

• If for some reason no video track is patched, or no audio track is patched 
then clips may not get inserted into the Timeline properly.  

• To patch or unpatch simply click inside the patching column with your 
mouse.  

• Only one video track can be patched at a time, and one audio track.  
  
 

WEEK 4 SUMMARY 
 
AUDIO 
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Audio Meters  
• Pay close attention to the Audio Meters next to the Timeline. 
• Volume is measured in decibels (db).  
• A simple rule to keep in mind is that the volume can get close to 0, 

but never go above 0.  
• Clipping occurs when the volume goes above 0, and the lights at 

the top of the Audio Meters will flash red. 

 
Rename Tracks 

• It is a best practice to assign a purpose to each audio track and to give it a 
meaningful name.  

• To rename a track, simply right-click on its name (such as Audio 1) and 
choose a different name.  

• If you can't see the track name, expand the track height until you can see it. 
You can do this by double clicking the empty space in the track header. 

• We named our tracks as follows: 
o Nat Sound 
o Dialogue 
o Music 

• Other common track names: Ambient, Interviews, SFX. 
  

 
 
 
Volume of a Clip 

• To adjust the volume of a single clip locate the horizontal white line and drag 
it up or down. 

• Dragging up increases the volume; dragging down decreases it.  
• To mute the clip, drag the white line all the way down to the very bottom 

until it can go no further.   
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Mute Track 

• To mute a track, simply click on the M button at the beginning of the track.   
• In some cases you may want to mute the entire Nat Sound track if it is 

random or distracting.  
• This will automatically mute all of the clips inside the track, which can save 

a lot of time.  
 

 
 
 
Adjusting Gain 

• Gain is another way to adjust the volume of a clip.  
• Right-click a clip in the Timeline and choose Audio Gain.  
• Choose Adjust Gain and enter a value such as 3. This will increase gain by 

3db.  
• You can also put in a negative number such as -3 or -6 to decrease the gain. 
• As always, pay close attention to the audio meters to make sure you never 

clip the audio.  
 
Normalizing Audio 

• Normalizing is one of the most efficient ways to set the volume of a clip.  
• Right-click on and audio clip and choose Audio Gain as we did before.  
• Select Normalize Max Peak and change the value to anything below 0 such 

as -3.  
• The entire audio waveform will be modified so that it peaks at the value you 

specified (such as -3db). This is a great time saver!  
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• Do not choose a value above 0 in this case or else the audio will clip.  
 

 
 
Keyframes 

• A keyframe allows you to change the value of something over time. In this 
case, you will change the volume of the music over time.  

• At times, you want the music to be loud. At other times, you want it to be 
quiet. Keyframes allow you to do this.  

 
Pen Tool 

• Select the Pen Tool from the Tools panel. This tool creates keyframes in the 
Timeline.  

• Then click directly on the white line in the music clip to add a keyframe.  
• Drag the keyframe down or up to change the volume.  
• Keep adding keyframes and adjusting them until you have the desired effect. 

Here is an example with 4 keyframes. The volume goes down, then later on 
comes back up.  

 

 
 
 
TRANSITIONS 
 
Default Transition 

• In the Timeline, right-click an edit point and choose Apply Default 
Transition. The default transition is the Cross Dissolve.  
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Transition Duration 

• To change a transition's duration, double-click it and enter a value.  
• The last number represents the number of frames, so 00:00:00:15 means 15 

frames.  
• If your footage was shot at 30 frames per second, then half a second would 

be 15 frames (00:00:00:15).  
• If your footage was shot at 24 frames per second, then half a second would 

be 12 frames (00:00:00:12). 
 
Other Transitions 

• Premiere Pro comes with many transitions that you can choose from.  
• All of the transitions are in the Effects panel, which can be activated by 

choosing Window > Effects from the top menu.  
• Open the Video Transitions folder and the Dissolve folder to see two 

common transitions: the Cross Dissolve and the Dip to Black.  
 

 
 

• Open the other folders to see the other transitions.  
• To add a transition, drag and drop it into the Timeline in between two clips.  

 
 
 
 
 
TRANSITION WORKFLOW 
 
Manually dragging transitions and changing their duration is laborious. Here are 
some handy techniques to speed up your workflow: 
 
Transition Duration 

• Default transition duration is 1 second, which is often too long.  
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• To  modify this, from the top menu choose Premiere Pro > Preferences 
(Mac) or Edit > Preferences (Windows) and then choose Timeline.  

• Change the Video Transition Default Duration to another value.  
• You can change the measurement to either Frames or Seconds. In this 

example, the duration is set to 0.5 5econds: 
 

 
 

• You could set it to 0.25 seconds, 15 frames, 10 frames or whatever you want.  
 
Apply Transitions Across Many Clips 

• Select multiple clips in the Timeline. You can do this by Shift-clicking with 
your mouse or dragging across several clips with your mouse.  

• From the top menu choose Sequence > Apply Video Transition. Keyboard 
shortcut for this is Cmd-D (Mac) or Ctrl-D (Windows). 

• Now the default transition will be applied across all of the selected clips.  
 
Change Default Transition 

• The default transition is the Cross Dissolve, but you can change this. 
• Go to the Effects panel and inside the Video Transitions folder locate the 

transition you want (such as the Dip to Black, Wipe or any other one).  
• Right-click the transition and choose Set Selected as Default Transition. 

Now it will be the default transition.  
 
 

WEEK 5 SUMMARY 
 
 EFFECTS  
 
Effects are powerful ways to add a professional touch to your video clips. There are 
over one hundred effects in Premiere Pro! And hundreds more available from third-
party developers.  
 
Effects Panel 

• The effects are located in the Effects panel.  
• From the top menu choose Window > Effects to make this panel visible.  
• In the Effects panel open the Video Effects folder to see all of the effects.  
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Warp Stabilizer 
• Instantly fix shaky footage!  
• Inside the Effects panel go into the Video Effects > Distort folder and locate 

the Warp Stabilizer effect.  
• You can also type in the word "warp" into the search box at the top of the 

Effects panel to locate it.  
• To apply an effect onto a clip simply drag it from the Effects panel directly 

onto a clip in the Timeline.  
• Wait a few seconds and the clip will automatically stabilize.  

 
Blur 

• Inside the Effects panel go into the Video Effects > Blur & Sharpen folder 
and locate the Gaussian Blur effect. 

• You can also type in the word "blur" into the search box at the top of the 
Effects panel to see all of the blur effects.  

• Drag the Gaussian Blur effect onto a clip in the Timeline.  
• Then in the Effect Controls panel (which is a completely different panel), 

next to Gaussian Blur, increase the Blurriness amount until the clip is blurry 
enough.   

 
Mask 

• By default the effect will apply to the entire clip.  
• But what if you just want to apply the effect to a specific portion of the 

image? Such as just blurring someone's face? You can create a Mask.  
• In the Effect Controls panel, immediately under the effect you will see 3 

options for masking: Ellipse, Rectangle and Free Draw: 
 

 
 

• Click on the mask of your choice and you will see it in the Program Monitor.  
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• From here, you can adjust the size of the mask by dragging the blue handles. 
• Move it by dragging it around.  
• In the Effect Controls panel you can also soften the edges by changing the 

Mask Feather amount.   
 

 
 
 

COLOR GRADING & CORRECTION 
 
Lumetri Color 

• Lumetri Color is such an important effect, that it has its own panel! 
• Activate this by choosing Window > Lumetri Color from the top menu.  
• You can also switch to the color workspace by choosing Window > 

Workspaces > Color from the top menu. Or choosing Color from the 
Workspaces panel (near top of screen): 
 

 
 
 

Basic Correction 
• Select a clip in the Timeline.  
• Then in the Lumetri Color panel, click on the Basic Correction tab to see all 

the values there: 
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• White Balance, adjusts the color balance from blue to orange.  
• Tint, adjusts the color balance from green to magenta. 
• Exposure is like Brightness.  
• Contrast, brights become brighter, darks become darker.  
• Highlights, adjusts the brightest portions of image.  
• Shadows, adjusts the darkest portions of image.  
• Saturation, adjusts intensity of the colors.  
• Using this panel properly will take some practice.  

 
BONUS 
 
Lumetri Scopes 

• How bright is too bright? How dark is too dark? A scope will tell you when 
your image is becoming overexposed or underexposed.  

• We are going to use the Waveform scope.    
• Open the Lumetri Scopes panel by choosing Window > Lumetri Scopes 

from the top menu.  
• Several scopes may appear. We are going to focus on the Waveform scope. 
• At the bottom of the Lumetri Scopes panel, click on the Wrench icon and 

uncheck all of the scopes except the Waveform. 
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• Click on the Wrench icon again and choose Waveform Type > Luma.  
 

 
 

• This scope shows the (brightness) of the image. The left axis goes from 0 to 
100.  
 

 
 

• If any part of the graph goes above 100 the image is overexposed. 
• If any part of the graph goes below 0 the image is underexposed. 
• Now you have some objective information to guide you during color grading.  

 
 

WEEK 6 SUMMARY 
 
Adding Text 

• In the Timeline, move your Playhead to the point where you would like to 
add some text.  
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• Choose the Type tool from the Tools panel.  

 
• Single-click anywhere inside the Program Monitor and start typing. The text 

will appear on-screen. For now, it will be the default size and color.  
 
Moving Text 

• Choose the Selection tool from the Tools panel. It is the tool at the very top.  
• Then click and drag the text in the Program Monitor wherever you want.  
• A Lower Third is text that appears in the lower part of the screen and 

provides useful information such as the name of a person or location. 
 
Safe Margins 

• This is a visual overlay that will help you place your text.  
• Right-click inside the Program Monitor and choose Safe Margins to turn 

them on.  
• Now two boxes will appear on-screen. The basic idea is that your text should 

be inside the boxes. 
• If the text gets too close to the edge of the screen it might get cropped on 

some people's screens.  
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Essential Graphics Panel 
• You will most likely want to modify the text properties such as font, size and 

color. We will use the Essential Graphics panel for this.  
• Switch to the Graphics workspace by choosing Window > Workspaces > 

Graphics from the top menu.  
• The Essential Graphics panel should appear on the right of your screen. If 

not, then choose Window > Essential Graphics from the top menu and it 
will appear.  

 
Modifying Text 

• Be sure the text clip is selected in the Timeline.  
• At the top of the Essential Graphics panel click on the Edit tab  

 

 
 

• This will bring up the text properties. Scroll down to see all the basic 
properties such as font, size, weight and several advanced ones too: 
 

 
 

• If you want to change the color, then modify the Fill color.  
• NOTE: If the Essential Graphics panel is blank then be sure to select the text 

clip inside the Timeline. And if necessary click on the text layer at the top of 
the Essential Graphics panel: 
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Duplicating Text 

• If you want to use the same text elsewhere in the Timeline, simply Opt-Drag 
(Mac) or Alt-Drag (Windows) the text clip and it will be duplicated.    

• This is very useful if you are planning to use the same styled text throughout 
the Timeline.  

 
Adding Graphics 

• At the end of the video we are going to create a layered graphic that includes 
3 layers: a colored background, logo and text.   

• You can layer clips one on top of the other inside the Timeline to do this. 
 
Color Matte 

• This will be the colored background. Choose File > New > Color Matte from 
the top menu. 

• For the Video Settings simply click on Ok.  
• Then choose any color you want or enter a color code if you have one.  
• Choose a name for the matte, or just accept the default name, Color Matte.  
• The Color Matte will now appear in the Project panel. Drag it into the 

Timeline.  
 
Adding Logo 

• From the Project panel, simply drag the logo into the Timeline immediately 
above the colored background (on Track 2): 
 

 
 

• If necessary you may have to import your logo first. 
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• For the best results, the logo should be on a transparent background. PNG 
files support transparency but JPG files do not.  

 
Adding Text 

• As we did previously, select the Type tool and single-click in the Program 
Monitor and start typing. Then modify its properties in the Essential Graphics 
panel.  

• Another text clip will appear inside the Timeline. 
• To add another text layer, click on the New Layer button near the top of the 

Essential Graphics panel and choose Text. 
 

  
 

• Now another text layer will appear that you can move and modify.   
 
Transitions 

• Now you should have 3 clips layered on top of each other in the Timeline.  
• Modify their durations, positions and add transitions to make it look more 

professional. You can be creative here. 
 

 
   
 
Replace Edit 

• Currently we have a Color Matte inside the Timeline. What if we wanted to 
replace it with another clip?  

• The slow way is to delete the Color Matte and then add another clip, but then 
you will have adjust the timing of the new clip and re-do all the transitions. 
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• Far quicker is a Replace Edit. 
• In the project panel, locate another clip and then Opt-Drag (Mac) or Alt-Drag 

(Windows) the clip over top of the Color Matte in the Timeline.  
• Release your mouse button and then release the Opt or Alt key. Now the 

color matte will be replaced with the new clip, and keep all the transitions! 
 
Fade Out Music 

• The fastest way to do this is with a transition.  
• Right-click the edge of the music clip and choose Apply Default Transitions. 

Now a crossfade transition will appear on the clip.  
• Double click the transition and change the duration to 00:00:02:00, which is 2 

seconds. Make it longer or shorter if you want.  
• Often a longer transition like 3 seconds will sound more smooth and 

professional.  
 
Export 

• To export a video, click anywhere inside the Timeline and choose File > 
Export > Media from the top menu. Then choose these settings:  

• From the Format menu choose H.264, which is a popular form of 
compression.  

• From the Preset menu choose Match Source - Adaptive High Bitrate 
• Click on the Output Name and browse to the 03-Final-Exports folder inside 

the project folder, or the location of your choice. Give the file a descriptive 
name.  

• After exporting you will end up with an MP4 file on your computer that you 
can share with the world!  

 
Congratulations! 
 

• You are well on your way to doing amazing things with Premiere Pro.  
• Gather some of your own footage and practice the skills you've learned 

here. Don't wait! Remember: "Use it or Lose it." 
• I'm looking forward to seeing your creations. Stay in touch! I would be happy 

to hear from you J 
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All the best, 
 
Navin Kulshreshtha 
Lead Instructor at Learn Premiere 

 
 
 
 
 


